Error calling IssueVendorTransfer in Logitech webcam

Aug 18, 2009 at 12:53 PM

Hi all,

i am using Logitech Webcam.

i am able to succsessfully run the application and stream from the camera First  time and getting following messages.

554964 PID:2a6001e TID:35f0012 Detected 2 decoders
 554964 PID:2a6001e TID:35f0012 Name  >B<
 554964 PID:2a6001e TID:35f0012 Desc  >W<
 554964 PID:2a6001e TID:35f0012
 554964 PID:2a6001e TID:35f0012 Name  >B<
 554965 PID:2a6001e TID:35f0012 Desc  >J<
 554965 PID:2a6001e TID:35f0012
 554969 PID:400002 TID:35f0012 MM buffer at 7003025c
 554969 PID:400002 TID:35f0012 MM buffer at 7003985c
 554969 PID:400002 TID:35f0012 MM buffer at 70042e5c
 554969 PID:400002 TID:35f0012 MM buffer at 7004c45c
 554969 PID:400002 TID:35f0012 MM buffer at 70055a5c
 554969 PID:400002 TID:35f0012 MM buffer at 7005f05c
 554969 PID:400002 TID:35f0012 pdd_StartVidStream++  Fmt 1
 555030 PID:400002 TID:35f0012 +USBD:OpenPipe, EP: 0x81, MaxPkt: 384, Type: Isoch
 555030 PID:400002 TID:35f0012 -USBD:OpenPipe success, hPipe = D1A841D0
 555046 PID:400002 TID:35f0012 StartVidStream--  rc 0
 555047 PID:2a6001e TID:35f0012 deviceioctl IOCTL_CAMERA_DEVICE_STARTVIDEOSTREAM returned 1.  dwBytes:0
 555366 PID:2a6001e TID:35f0012 deviceioctl IOCTL_CAMERA_DEVICE_GETNEXTVIDEOFRAME returned 1.  dwBytes:16

But as i am stopping the preview once and starting it again . I am getting the following failure message and not able to see any streaming from the camera.

 

765834 PID:21d0022 TID:3920022 Detected 2 decoders
 765834 PID:21d0022 TID:3920022 Name  >B<
 765834 PID:21d0022 TID:3920022 Desc  >W<
 765834 PID:21d0022 TID:3920022
 765834 PID:21d0022 TID:3920022 Name  >B<
 765834 PID:21d0022 TID:3920022 Desc  >J<
 765834 PID:21d0022 TID:3920022
 765838 PID:400002 TID:3920022 MM buffer at 7003025c
 765838 PID:400002 TID:3920022 MM buffer at 7003985c
 765838 PID:400002 TID:3920022 MM buffer at 70042e5c
 765838 PID:400002 TID:3920022 MM buffer at 7004c45c
 765838 PID:400002 TID:3920022 MM buffer at 70055a5c
 765838 PID:400002 TID:3920022 MM buffer at 7005f05c
 765838 PID:400002 TID:3920022 pdd_StartVidStream++  Fmt 1
 765845 PID:400002 TID:3920022 WebCam: Error calling IssueVendorTransfer rc: 31  ExtErr: 31
 765845 PID:400002 TID:3920022 WebCam: Error setting original probe vals  rc 31
 767849 PID:400002 TID:3920022 WebCam: Error calling IssueVendorTransfer rc: 1460  ExtErr: 1460
 767853 PID:400002 TID:3920022 WebCam: Error calling IssueVendorTransfer rc: 31  ExtErr: 31
 767853 PID:400002 TID:3920022 WebCam: Error setting original probe vals  rc 31
 767893 PID:400002 TID:3920022 WebCam: Error calling IssueVendorTransfer rc: 31  ExtErr: 31
 767894 PID:400002 TID:3920022 WebCam: Error calling IssueVendorTransfer rc: 31  ExtErr: 31
 767894 PID:400002 TID:3920022 WebCam: Error setting original probe vals  rc 31
 767894 PID:400002 TID:3920022 Probe/Commit failed.  Not enough bandwidth for Fmt: 1  Frm: 1
 767894 PID:400002 TID:3920022 WebCam: Probe/Commit failed.  Not enough bandwidth for Fmt: 1  Frm: 1
 767894 PID:400002 TID:3920022 StartVidStream--  rc 31
 767895 PID:21d0022 TID:3920022 deviceioctl IOCTL_CAMERA_DEVICE_STARTVIDEOSTREAM returned 0.  dwBytes:0
 767895 PID:21d0022 TID:3920022 failure calling IOCTL_CAMERA_DEVICE_STARTVIDEOSTREAM rc 31
 767895 PID:21d0022 TID:3920022 ReadFrameThread--

 

Webcam starts working only if i detach and attach it again .

can anybody help me on this.

 

Nov 24, 2009 at 7:27 AM

Hi, I get even problem!

Please help me!!!

 

Feb 23, 2010 at 4:28 AM

I have same symptom.

But I got same message at first.
Of cource, No successful.

I doubt a communication of driver and device.
Driver use fixed unit ID (this is 0) for all cases.

I think this fixed unit ID maybe not perfect.