WebCam: Next Frame event not signaled rc 258

Nov 5, 2008 at 2:43 PM
Edited Nov 6, 2008 at 9:03 AM

Hello,

Currently I am trying to render YUV on screen, but this does not appear to work at certain resolutions.

These resolutions are returned when I use the IOCTL_CAMERA_DEVICE_GETVIDEOFORMAT with wFormatIndex = 2 (YUV/uncompressed):

From 5 to 30fps (increments of 5fps):
160x120
176x144
320x240
352x288
640x480

800x600 @ 5-25fps (inc 5fps)

960x720 @ 5 and 10fps
1600x1200 @5fps

However, I have not been able to get a frame from 640x480 and higher. The following error is shown in the debugconsole:
WebCam: Next Frame event not signaled rc 258 <- WAIT_TIMEOUT error (occurs @ waitforsingleobject)

MJPEG does work, it does start off with the same error message, but starts working successfully after 5 seconds, even using the highest supported resolution of 800x600.
this also randomly occurs in lower resolutions, especially when a higher framerate is set (above 176x144 @10fps the same problem occurs).

When looked at the packet header of every packet in the frame (which is returned from the webcam), the following is returned from the cam (3 examples of such packet headers):
0C CC 49 19 EC EE FD 72 38 EF DB 06
0C CC 49 19 EC EE 6C 8A 38 EF DC 06
0C CC 49 19 EC EE DC A1 38 EF DC 06
(this slightly varies for every packet in the frame)

This is on CE 6.0 with a Logitech Quickcam pro 9000. Does anyone have a clue why this occurs and how this can be solved?

Thanks in advance

 

Mar 4, 2009 at 12:23 PM
I always get the same error:

WebCam: Next Frame event not signaled rc 258

Any luck lately? And did you try changing the timeout value?
Apr 1, 2009 at 12:06 PM
That was actually a valid message while we never had any data transferred over the USB.

Mar 22, 2013 at 3:24 PM
Question, I am running into similar problem with rc-258, would you mind if I ask you how you resolved your issue? Please let me know.

http://cewebcam.codeplex.com/discussions/437577